Office 365 Service Expiration Notices
Incident Report for GT OIT
Resolved
Approximately 4,500 users were erroneously notified last night and this morning (May 15/16) that their Office 365 Services were beginning to expire within 30 days. If your Office 365 services are legitimately expiring, you should receive a follow-up notice later this week with the correct expiration date.

Notices have been sent to the users who received the incorrect message.
Posted about 1 month ago. May 16, 2017 - 14:20 EDT
Monitoring
Approximately 4,500 users were erroneously notified last night and this morning (May 15/16) that their Office 365 Services were beginning to expire within 30 days. If your Office 365 services are legitimately expiring, you should receive a follow-up notice later this week with the correct expiration date.

We apologize for the misinformation and are working to identify a solution to prevent this from reoccurring in the future.
Posted about 1 month ago. May 16, 2017 - 07:57 EDT
Investigating
We have been made aware that some users were erroneously notified last night and this morning (May 15/16) that their Office 365 Services were beginning to expire within 30 days.

We apologize for the misinformation and are working to identify why this occurred and how to keep it from reoccurring in the future.
Posted about 1 month ago. May 16, 2017 - 06:32 EDT
This incident affected: Email (Office 365 Outlook).