web-plesk9 is currently down.
Incident Report for GT OIT
Resolved
The web-plesk9 issue is now cleared and hosted sites are working again.
Posted 5 months ago. Jun 14, 2017 - 08:04 EDT
Investigating
web-plesk9 is currently down. Web team is looking into the issue.
Posted 5 months ago. Jun 14, 2017 - 05:55 EDT
This incident affected: Web Hosting.